![]() |
|
Guide How to Fix PHP2Shell (CVE-2026-109618/109619) on Plesk - Printable Version +- AdminsForum (https://adminsforum.com) +-- Forum: Commercial control panels (https://adminsforum.com/Forum-commercial-control-panels) +--- Forum: Plesk (https://adminsforum.com/Forum-plesk) +---- Forum: Plesk Guides & Tutorials (https://adminsforum.com/Forum-plesk-guides-tutorials) +----- Forum: Plesk Security Guides (https://adminsforum.com/Forum-plesk-security-guides) +----- Thread: Guide How to Fix PHP2Shell (CVE-2026-109618/109619) on Plesk (/Thread-guide-how-to-fix-php2shell-cve-2026-109618-109619-on-plesk) |
How to Fix PHP2Shell (CVE-2026-109618/109619) on Plesk - JAY - 10-22-2026 How to Fix PHP2Shell (CVE-2026-109618/109619) on Plesk On 21 October 2026 PHP released emergency fixes for two critical bugs, CVE-2026-109618 and CVE-2026-109619 ("PHP2Shell"). They can let an attacker run code on your server without logging in, and attacks are already happening. This guide shows how to patch a server running Plesk, step by step. New to PHP2Shell? Read the overview first: PHP2Shell explained: what it is and how to fix it. The fixed versions Your PHP must be at least: 8.5.12, 8.4.27, 8.3.36 or 8.2.35. Older branches (7.4 to 8.1) need a patched build from your vendor. Update every PHP version installed, not just the one your main site uses. Step 1: See which PHP versions you have In Plesk, go to Tools & Settings > PHP Settings to see every PHP handler and its version. From the terminal: Code: plesk bin php_handler --listStep 2: Update the PHP components In the panel: Tools & Settings > Updates (Plesk Installer) and install the available component updates. Or from the terminal, as root: Code: plesk installer --select-release-current --upgrade-installed-componentsStep 3: Restart PHP-FPM Code: systemctl list-units --type=service | grep -i 'plesk-php.*fpm'
systemctl restart plesk-php83-fpm # repeat for each one listed
plesk bin php_handler --rereadStep 4: Confirm Run Code: plesk bin php_handler --listCheck the version your websites really use The command line can show a different PHP from the one serving websites. To be sure, create a file called Code: v.phpCode: <?php echo PHP_VERSION;Code: https://your-domain/v.phpCan't update yet? Temporary protection These settings reduce the risk until a patched version is installed. They are not a full fix. Add them to the php.ini of each PHP version (Tools & Settings > PHP Settings, click a PHP version, then php.ini), then restart PHP: Code: session.upload_progress.enabled = 0
; PHP 8.5 only:
fatal_error_backtraces = 0Code: ini_set()Code: .user.iniCode: memory_limit = -1After patching: check you weren't hit Attacks started on 17 October, before the fix existed. Spend ten minutes on these checks:
Questions? Ask in Plesk Security Support with your OS, Plesk version and the output of your PHP version check. Sources (checked 22 October 2026): Tenable PHP2Shell FAQ ยท Qualys: mitigate and patch PHP2Shell |