![]() |
|
Guide How to Fix PHP2Shell (CVE-2026-109618/109619) on cPanel & WHM - Printable Version +- AdminsForum (https://adminsforum.com) +-- Forum: Commercial control panels (https://adminsforum.com/Forum-commercial-control-panels) +--- Forum: cPanel & WHM (https://adminsforum.com/Forum-cpanel-whm) +---- Forum: cPanel & WHM Guides & Tutorials (https://adminsforum.com/Forum-cpanel-whm-guides-tutorials) +----- Forum: cPanel Security Guides (https://adminsforum.com/Forum-cpanel-security-guides) +----- Thread: Guide How to Fix PHP2Shell (CVE-2026-109618/109619) on cPanel & WHM (/Thread-guide-how-to-fix-php2shell-cve-2026-109618-109619-on-cpanel-whm) |
How to Fix PHP2Shell (CVE-2026-109618/109619) on cPanel & WHM - JAY - 10-22-2026 How to Fix PHP2Shell (CVE-2026-109618/109619) on cPanel & WHM On 21 October 2026 PHP released emergency fixes for two critical bugs, CVE-2026-109618 and CVE-2026-109619 ("PHP2Shell"). They can let an attacker run code on your server without logging in, and attacks are already happening. This guide shows how to patch a server running cPanel & WHM, step by step. New to PHP2Shell? Read the overview first: PHP2Shell explained: what it is and how to fix it. The fixed versions Your PHP must be at least: 8.5.12, 8.4.27, 8.3.36 or 8.2.35. Older branches (7.4 to 8.1) need a patched build from your vendor. Update every PHP version installed, not just the one your main site uses. Step 1: See which PHP versions you have cPanel's PHP versions come from EasyApache 4 and are named Code: ea-php82Code: ea-php83Code: for p in /opt/cpanel/ea-php*/root/usr/bin/php; do echo "$p $($p -r 'echo PHP_VERSION;')"; doneStep 2: Update the ea-php packages If automatic updates are on, cPanel installs new EasyApache packages in its nightly update. To update now, as root: Code: dnf clean all
dnf update 'ea-php*' 'ea-apache24*'Code: yumCode: dnfIf your server runs CloudLinux with alt-php, also update those: Code: dnf update 'alt-php*'Code: lsphp*Step 3: Restart Apache and PHP-FPM Code: /scripts/restartsrv_httpd
/scripts/restartsrv_apache_php_fpmCode: /usr/local/lsws/bin/lswsctrl restartStep 4: Confirm Run the version loop from Step 1 again. Every ea-php version should show a fixed version. Check the version your websites really use The command line can show a different PHP from the one serving websites. To be sure, create a file called Code: v.phpCode: <?php echo PHP_VERSION;Code: https://your-domain/v.phpCan't update yet? Temporary protection These settings reduce the risk until a patched version is installed. They are not a full fix. Add them to the php.ini of each PHP version (WHM > Software > MultiPHP INI Editor > Editor Mode for each PHP version), then restart PHP: Code: session.upload_progress.enabled = 0
; PHP 8.5 only:
fatal_error_backtraces = 0Code: ini_set()Code: .user.iniCode: memory_limit = -1After patching: check you weren't hit Attacks started on 17 October, before the fix existed. Spend ten minutes on these checks:
Questions? Ask in cPanel Security Support with your OS, cPanel & WHM version and the output of your PHP version check. Sources (checked 22 October 2026): Tenable PHP2Shell FAQ ยท Qualys: mitigate and patch PHP2Shell |