![]() |
|
Guide How to Fix PHP2Shell (CVE-2026-109618/109619) on HestiaCP - Printable Version +- AdminsForum (https://adminsforum.com) +-- Forum: Free & open-source control panels (https://adminsforum.com/Forum-free-open-source-control-panels) +--- Forum: HestiaCP (https://adminsforum.com/Forum-hestiacp) +---- Forum: HestiaCP Guides & Tutorials (https://adminsforum.com/Forum-hestiacp-guides-tutorials) +----- Forum: HestiaCP Security & Firewall Guides (https://adminsforum.com/Forum-hestiacp-security-firewall-guides) +----- Thread: Guide How to Fix PHP2Shell (CVE-2026-109618/109619) on HestiaCP (/Thread-guide-how-to-fix-php2shell-cve-2026-109618-109619-on-hestiacp) |
How to Fix PHP2Shell (CVE-2026-109618/109619) on HestiaCP - JAY - 10-22-2026 How to Fix PHP2Shell (CVE-2026-109618/109619) on HestiaCP On 21 October 2026 PHP released emergency fixes for two critical bugs, CVE-2026-109618 and CVE-2026-109619 ("PHP2Shell"). They can let an attacker run code on your server without logging in, and attacks are already happening. This guide shows how to patch a server running HestiaCP, step by step. New to PHP2Shell? Read the overview first: PHP2Shell explained: what it is and how to fix it. The fixed versions Your PHP must be at least: 8.5.12, 8.4.27, 8.3.36 or 8.2.35. Older branches (7.4 to 8.1) need a patched build from your vendor. Update every PHP version installed, not just the one your main site uses. Step 1: See which PHP versions you have HestiaCP runs several PHP-FPM versions side by side, installed from the Debian/Ubuntu PHP repository. List them: Code: ls /etc/php/
dpkg -l | grep -E 'php8\.[0-9]+-fpm'Step 2: Update PHP with apt Take a snapshot of the server first. Then, as root: Code: apt update
apt list --upgradable 2>/dev/null | grep -i php
apt -y upgradeCode: hestia-phpCode: apt upgradeStep 3: Restart PHP-FPM Restart every PHP-FPM version with Hestia's own command: Code: for v in /etc/php/*/fpm; do s="php$(basename $(dirname $v))-fpm"; v-restart-service "$s" && echo "restarted $s"; doneStep 4: Confirm Check the installed package versions: Code: dpkg -l | grep -E 'php8\.[0-9]+-fpm'Code: zcat /usr/share/doc/php8.3-fpm/changelog.Debian.gz 2>/dev/null | grep -m3 -E 'CVE-2026-10961[89]'Check the version your websites really use The command line can show a different PHP from the one serving websites. To be sure, create a file called Code: v.phpCode: <?php echo PHP_VERSION;Code: https://your-domain/v.phpCan't update yet? Temporary protection These settings reduce the risk until a patched version is installed. They are not a full fix. Add them to the php.ini of each PHP version ( Code: /etc/php/8.x/fpm/php.iniCode: session.upload_progress.enabled = 0
; PHP 8.5 only:
fatal_error_backtraces = 0Code: ini_set()Code: .user.iniCode: memory_limit = -1After patching: check you weren't hit Attacks started on 17 October, before the fix existed. Spend ten minutes on these checks:
Questions? Ask in HestiaCP Security & Firewall Support with your OS, HestiaCP version and the output of your PHP version check. Sources (checked 22 October 2026): Tenable PHP2Shell FAQ ยท Qualys: mitigate and patch PHP2Shell |