![]() |
|
Guide How to Fix PHP2Shell (CVE-2026-109618/109619) on FASTPANEL - Printable Version +- AdminsForum (https://adminsforum.com) +-- Forum: Free & open-source control panels (https://adminsforum.com/Forum-free-open-source-control-panels) +--- Forum: FASTPANEL (https://adminsforum.com/Forum-fastpanel) +---- Forum: FASTPANEL Guides & Tutorials (https://adminsforum.com/Forum-fastpanel-guides-tutorials) +----- Forum: FASTPANEL Security & Firewall Guides (https://adminsforum.com/Forum-fastpanel-security-firewall-guides) +----- Thread: Guide How to Fix PHP2Shell (CVE-2026-109618/109619) on FASTPANEL (/Thread-guide-how-to-fix-php2shell-cve-2026-109618-109619-on-fastpanel) |
How to Fix PHP2Shell (CVE-2026-109618/109619) on FASTPANEL - JAY - 10-22-2026 How to Fix PHP2Shell (CVE-2026-109618/109619) on FASTPANEL On 21 October 2026 PHP released emergency fixes for two critical bugs, CVE-2026-109618 and CVE-2026-109619 ("PHP2Shell"). They can let an attacker run code on your server without logging in, and attacks are already happening. This guide shows how to patch a server running FASTPANEL, step by step. New to PHP2Shell? Read the overview first: PHP2Shell explained: what it is and how to fix it. The fixed versions Your PHP must be at least: 8.5.12, 8.4.27, 8.3.36 or 8.2.35. Older branches (7.4 to 8.1) need a patched build from your vendor. Update every PHP version installed, not just the one your main site uses. Step 1: See which PHP versions you have In FASTPANEL, open the menu (top left) and go to Applications, then search for php. Note every PHP version that is installed. Your sites can use different versions, so check each site's PHP setting too. From the terminal, this finds every PHP binary on the server: Code: ls /etc/php/ /opt/ 2>/dev/null
for b in $(ls /usr/bin/php[0-9]* /opt/php*/bin/php 2>/dev/null); do echo "$b $($b -r 'echo PHP_VERSION;')"; doneStep 2: Update PHP Take a snapshot of the server first. Check for PHP package updates with apt: Code: apt update
apt list --upgradable 2>/dev/null | grep -i php
apt -y upgradeStep 3: Restart PHP-FPM Code: systemctl list-units --type=service | grep -i 'php.*fpm'
systemctl restart php8.3-fpm # repeat for each service listedStep 4: Confirm Run the version loop from Step 1 again, and do the browser check below for at least one site per PHP version. Check the version your websites really use The command line can show a different PHP from the one serving websites. To be sure, create a file called Code: v.phpCode: <?php echo PHP_VERSION;Code: https://your-domain/v.phpCan't update yet? Temporary protection These settings reduce the risk until a patched version is installed. They are not a full fix. Add them to the php.ini of each PHP version (or the site's PHP settings in FASTPANEL), then restart PHP: Code: session.upload_progress.enabled = 0
; PHP 8.5 only:
fatal_error_backtraces = 0Code: ini_set()Code: .user.iniCode: memory_limit = -1After patching: check you weren't hit Attacks started on 17 October, before the fix existed. Spend ten minutes on these checks:
Questions? Ask in FASTPANEL Security & Firewall Support with your OS, FASTPANEL version and the output of your PHP version check. Sources (checked 22 October 2026): Tenable PHP2Shell FAQ ยท Qualys: mitigate and patch PHP2Shell |